Updating our security levels

Dear Publishers,

A quick housekeeping item to discuss before the weekend:

We are updating our security levels here at PressReader.  As a result, some of the older browsers will no longer work on our secure pages.

This upgrade may impact some of your readers who are still using these older browsers to read your content. We recommend notifying them about the recent changes as soon as possible.

Here is a list of browsers that will support our secure pages moving forward:

  •  Internet Explorer 7 and later
  •  Firefox 2
  •  Opera 8 with TLS 1.1 enabled
  •  Google Chrome:
    •  Supported on Windows XP on Chrome 6 and later
    •  Supported on Vista and later by default
    •  OS X 10.5.7 in Chrome Version 5.0.342.0 and later
  •  Safari 2.1 and later (requires OS X 10.5.6 and later or Windows Vista and later).
  •  Note: No versions of Internet Explorer on Windows XP support SNI

Many thanks,

The PressReader team.