PressReader’s servers not compromised by recent Heartbleed bug

We wanted to let everyone know that PressReader’s servers have passed all vulnerability tests and are not compromised by the recent Heartbleed bug.

We take personal data protection very seriously and continuously work to provide our customers worldwide with the utmost secure experience.

If you have any further questions on this topic, please don’t hesitate to reach out to us at digitalsupport[at]pressreader.com.

Thanks!
The PressReader Team